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Erstellen und Ändern von Bibliotheken mit Eagle 4.09 
 
Eine Bibliothek besteht in der Regel aus drei Bestandteilen/Elementen: 
• Package: Das Gehäuse auf der Platine, inkl. Footprint und Platinenbeschriftung 
• Symbol: Die Darstellung des Bauteils im Schaltplaneditor 
• Device: Die Kombination aus Symbol und Package 
 
Zum Erstellen einer neuen Bibliothek gehen Sie bitte im Control Panel auf 
File->New->Library. Zum editieren einer bestehenden Bibliothek auf 
File->Open->Library oder in der Baumdarstellung vom Control Panel mit der rechten 
Maustaste auf eine Bibliothek klicken und Open auswählen. Es öffnet sich nun der 
Library-Editor. 
 
Falls Sie eine neue Bibliothek erstellt haben, speichern Sie sie über File->Save as 
unter einem neuen Namen, z.B. Atmel RF. Achten Sie dabei auf das richtige 
Verzeichnis, in Eagle können nur Bibliotheken verwendet werden, die in einem 
eingebundenen Verzeichnis abgelegt sind. Gegebenenfalls binden Sie ein neues 
Verzeichnis im Control Panel über Options->Directories ein. 
 
Vergessen Sie nicht während der folgenden Schritte die Bibliothek in regelmäßigen 
Zeitabständen zu speichern. 
 
Um die Bezeichnungen von den einzelnen Packages, Symbolen oder Devices zu 
ändern wählen Sie den jeweiligen Editier-Modus aus (siehe jeweils 1. Schritt in den 
unteren Punkten) und tippen Sie in die Befehlsleiste folgendes ein: 
rename ‘alter name‘ ‘neuer name‘ 
Um eins der Elemente zu löschen tippen Sie 
del ‘name‘ oder remove ‘name‘ 
Die Anführungszeichen brauchen Sie nicht miteinzutippen. 
 
Um ein neues Bauteil zu kreieren arbeiten Sie nun folgende Schritte nacheinander 
ab. Falls Sie eine bestehende Bibliothek verändern, können Sie auch bestehende 
Elemente der Bibliothek nutzen. Dazu öffnen Sie einfach das vorhandene Element, 
statt es neu zu erstellen, wenn sie bei dem entsprechendem Schritt angelangt sind. 

Package 
 
1. Gehen Sie in den Package-Editier-Modus in der oberen Iconleiste. In das sich 

öffnende Fenster tragen Sie im Feld New den Namen des neuen Gehäuses ein. 
Für ein Widerstand beispielsweise R-10 oder für ein 20 poliges SMD-IC SSOP20. 

 
2. Stellen Sie mit dem GRID-Befehl nun das passende Raster ein. Für 

Standardelemente wird das in der Regel 0.05 Inch sein. Bei SMD-Elementen ein 
feineres Raster. Die hier festgelegte Einheit wird bei allen Größenangaben im 
Editor genutzt, sie kann jedoch jederzeit geändert werden. 

 
3. Bei einem bedrahteten Standardbauelement wählen Sie PAD und legen in der 

oberen Leiste die Parameter fest. Die Form und die Größe des Pads und den 
Bohr - 1 -durchmesser. Achten Sie dabei auf die eingestellte Maßeinheit. Die 
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Padgröße können Sie auf Auto stehen lassen. Damit wird die endgültige Größe 
aus den verwendeten Design Rules ermittelt. 
Der Zeichnungsnullpunkt ist später der Aufhängepunkt des Bauteils an dem es 
später selektiert wird. 

 
4. Bei einem SMD-Bauteil wählen Sie SMD und stellen in der oberen Leiste die 

Parameter für das Pad ein. Die Maße können Sie entweder aus den vorgegeben 
Werten auswählen oder direkt von Hand in das Feld eintippen (Maßeinheit 
beachten). 
Als Layer belassen Sie bitte Top, auch wenn das Bauteil später auf die Unterseite 
der Platine kommt. SMD-Bauteile werden später auf der Platine mit dem 
MIRROR-Befehl auf die andere Seite gebracht. Dabei wandern die Elemente in 
allen t..-Layern in die entsprechenden b..-Layer, 
Um runde Pads zu erhalten ändern Sie den Parameter Roundness auf 100%. 

 
5. Mit dem NAME-Befehl können den Pads Namen vergeben werden. z.B. 1 und 2. 

(Um die Pads automatisch fortlaufend zu numerieren, tippen Sie in die 
Commandozeile folgendes ein: smd 1.3 x 0.5 ‘1‘  Die Hochkommas müssen 
miteingegeben werden. Die Zahlen 1.3 und 0.5 geben die Größe der Kupferfläche 
an und können natürlich auch anders lauten. Die ‘1‘ gibt die Startnummer für die 
Pinnummerierung an.) 
Die hier eingegebenen Namen/Nummern erscheinen später im Schalplan über 
den Pins. 

 
6. In den Layer 21 tPlace können Sie nun das Bestückungsplan-Symbol 

einzeichnen. Dieser Layer enthält den Platinenaufdruck. Bei Bedarf können Sie 
hier auch ein anderes Raster verwenden, siehe 2. 
Achten Sie im Layer 21 darauf, dass die Lötflächen nicht überdeckt werden. Falls 
Sie eine realistische Darstellung wünschen, die auch für gedruckte Unterlagen 
verwendet werden kann, wählen sie Layer 51 tDocu. So kann der eigentliche 
Körper des Bauteils im Layer 21 gezeichnet werden und die Linien, die zu den 
Pads führen im Layer 51. 

 
7. Mit dem TEXT-Befehl plazieren Sie die Texte >NAME (im Layer 25 tNames) und 

>VALUE (im Layer 27 tValues) dort, wo auf dem Board der aktuelle Name und 
der aktuelle Wert des Bauteils erscheinen soll. 

 
8. Mit dem CHANGE-Befehl können Sie nachträglich die Eigenschaften der Objekte 

ändern. Wählen Sie dazu den Parameter aus, den Sie ändern möchten und 
klicken auf das zu ändernde Objekt. 

 
9. Mit Description können Sie das Package beschreiben. Für die Formatierung der 

Beschreibung gelten dabei HTML ähnliche Befehle: 
<b></b> schließt einen fett gedruckten Text ein 
<i></i> schließt einen kursiv gedruckten Text ein 
<author></author> schließt die Autorangabe ein 
<br> erzwingt einen Zeilenumbruch 
<p> erzwingt einen neuen Absatz 
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Package Import 
Falls Sie ein bereits bestehendes Package aus einer anderen Bibliothek importieren 
möchten, gehen Sie bitte folgendermaßen vor. 
 
1. Speichern Sie ihre aktuelle Bibiothek. 
2. Öffnen Sie die Bibliothek, in der das gewünschte Package vorhanden ist. Wählen 

Sie dazu File->Open. 
3. Öffnen sie dort das gewünschte Package mit entsprechend Symbol und klicken 

Sie auf OK. 
4. Mit dem GROUP-Befehl markieren Sie nun die Teile des Packages die Sie 

kopieren möchten. 
5. Mit dem CUT-Befehl werden diese Bereiche in die Zwischenablage kopiert.  
 
6. Wiederholen Sie nun Schritte 2 und 3, um Ihr ursprünglich bearbeitetes Package 

zu öffnen. 
7. Mit dem PASTE-Befehl fügen sie den kopierten Bereich in Ihr Package ein.  
 
 

Symbol 
 
1. Wählen Sie den Symbol-Editier-Modus , in dem sich öffnenden Fenster tragen 

Sie den neuen Namen für das Symbol ein. Dieser Name erscheint später nicht in 
der Schaltung, dennoch sollten sie auf den Wiedererkennungswert achten, um 
die gesuchten Symbole später schnell wiederfinden zu können. 

 
2. Stellen Sie als Raster 0.1 Inch ein, da Eagle auf diese Raster ausgerichtet ist und 

die meisten anderen Bibliotheken dieses Raster verwenden. Falls Sie unbedingt 
ein anderes Raster benötigen stellen Sie bitte ein ganzes Vielfaches oder 
Bruchteil von 0.1 Inch ein. Beispielsweise 0.2, 0.3, 0.05, 0.025, etc ein. Sonst wird 
später das Verdrahten des Symbols in der Schaltung nicht möglich sein. 

 
3. Wählen Sie nun den PIN-Befehl aus. In der oberen Leiste können Sie die 

Parameter für die Pins einstellen, z.B. Länge, Aussehen und Beschriftungsarten. 
Mit der linken Maustaste plazieren sie die Pins, mit der rechten Maustaste können 
die Pins rotiert werden. 
Der Parameter Swaplevel besagt, dass die Pins mit dem gleichen Swaplevel 
untereinander mit dem Befehl PINSWAP austauschbar sind. Wobei Swaplevel 0 
bedeutet, dass der Pin mit keinem anderen austauschbar ist. 
Parameter Direction hat Einfluß auf das ERC. Wählt man z.B. Out aus und 
verbindet diesen Pin später mit der Masse, gibt ERC eine Warnung aus. Ist In als 
Direction In ausgewählt und der Pin bleibt unbeschaltet, erfolgt auch ein 
Warnung. Ferner werden alle Pwr Pins mit dem gleichen Namen später im 
Platinenlayut einer Schaltung automatisch von Eagle verbunden, selbst wenn die 
Verbindung im Schematic nicht angezeigt wird. 

 
4. Alle diese Parameter können später auch mit dem CHANGE-Befehl geändert 

werden. 
Mit demselben Befehl können, über CHANGE->Direction->..., die Eigenschaften 
der Pins geändert werden. 
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5. Mit dem NAME-Befehl können die Pins umbenannt werden. Sinnvollerweise 
geben Sie den Pins Namen, wie sie in dem Datenblatt des Bauteils benannt sind. 
Leider lässt sich die Textgröße nicht ändern. 
Es gibt dazu jedoch eine Lösungsmöglichkeit, die mit einigem Aufwand 
verbunden ist. Dazu bitte über Change->Visible->Pad auswählen und damit alle 
Pins bearbeiten. Damit werden später die Namen der Pins in der Schaltung 
ausgeblendet und nur die Padnamen des Gehäuses sind zu sehen. Um die 
Beschriftungen für die Pins in der Schaltung trotzdem zu haben, wählt man nun 
Text aus, gibt die Namen der Pins nochmals ein. Die neu eingegebenen Namen 
plaziert man gegenüber den Pins in beliebiger Größe im Names-Layer. 

 
6. Wenn die Pins plaziert sind, können sie den Raster ändern, z.B. feiner einstellen. 

Mit den Zeichenbefehlen können Sie nun den Schaltplanzeichen des Bauteils 
nachzeichnen. Verbleiben Sie dabei bitte im Symbol-Layer 94. 
 
 

 
7. Mit dem TEXT-Befehl plazieren Sie die Texte >NAME (im Layer 95 Names) und 

>VALUE (im Layer 96 Values) dort, wo auf dem Board der aktuelle Name und der 
aktuelle Wert des Bauteils erscheinen soll. 

 
8. Mit Description können Sie das Symbol beschreiben. Für die Formatierung der 

Beschreibung gelten dabei HTML ähnliche Befehle: 
<b></b> schließt einen fett gedruckten Text ein 
<i></i> schließt einen kursiv gedruckten Text ein 
<author></author> schließt die Autorangabe ein 
<br> erzwingt einen Zeilenumbruch 
<p> erzwingt einen neuen Absatz 

 

Symbol Import 
Gehen Sie dabei wie beim Import von Packages vor. 
 

Extra Power Pins 
Um externe Pins für die Schaltungserstellung zu definieren und damit die 
Übersichtlichkeit des Schalplans zu erhöhen gehen Sie folgendermaßen vor. 
 
1. Legen Sie ein neues Symbol an, vergeben Sie dabei den Namen PWRN oder 

etwas ähnlich einprägsames. 
2. Plazieren Sie dort zwei Pins und vergeben Sie denen 

die Namen GND und Vcc. 
3. Über den CHANGE->DIRECTION->Pwr ändern Sie die 

Eigenschaft der Pins. 
 
Das neue Symbol muss in etwa so, wie das rechts 
abgebildete aussehen. 
 
Für weiteres Vorgehen siehe Device, Extra Power Pins. 
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Device 
 
1. Legen Sie nun ein neues Device an. In das sich öffnende Fenster tragen Sie im 

Feld New den neuen Namen ein. Für ein Widerstand Beispielsweise R oder für 
ein IC 7400 oder 74*00. Das * ist dabei ein Platzhalter für die verschiedenen 
Technologien, z.B. L-, LS-, HC-Technologie. 
Die Package-Variante wird automatisch am Ende der Bezeichnung eingefügt. 
Möchte man die diese Bezeichnung am Anfang des Namens stehen haben, muss 
beim Namen des Device-Namens ? am Anfang eingefügt werden, also z.B. 
?74*00 (siehe auch 2. und 8.). Mit Klick auf OK wird das neue Device angelegt. 

 
2. Im neuen Fenster können Sie nun mit dem Klick auf New, rechts unten ein neues 

Package zuordnen. In dem sich öffnenden Fenster können Sie die zuvor 
erstellten Packages auswählen und im Feld Variant Name das Kürzel eintragen, 
das den ? Platzhalter nutzt und an dem die verschiedenen Packages ein und des 
selben ICs unterschieden werden. 

 
3. Mit dem PREFIX-Button legt man den Namen fest, der in der Schaltung 

automatisch vergeben wird. Für ein IC beispielsweise IC. Die Numerierung erfolgt 
automatisch. 

 
4. Mit dem VALUE-Schalter legen Sie fest, ob der Wert des Device in der Schaltung 

verändert werden kann. Bei einem IC kann der Schalter auf Off gesetzt werden, 
bei einem Widerstand ist es dagegen zwingend erforderlich den Wert auf On zu 
setzten. 

 
5. Mit dem ADD fügen Sie das vorher definierte Symbol in das Device. Besteht das 

Device aus mehreren Schaltsymbolen, die unabhängig voneinander in der 
Schaltung plaziert können werden sollen (in Eagle Gates genannt), fügen Sie 
jedes Gate einzeln hinzu. 
Stellen Sie als Parameter Addlevel Next und Swaplevel ein und plazieren Sie das 
Gate in der Nähe des Nullpunktes. 
Der Parameter Swaplevel besagt, dass die Gates mit dem gleichen Swaplevel 
untereinander mit dem Befehl GATESWAP austauschbar sind. Wobei Swaplevel 
0 bedeutet, dass das Gate mit keinem anderen austauschbar ist. 

 
6. Mit dem NAME-Befehl können Sie den Namen des oder der Gates ändern. Bei 

einem Device mit einem Gate spielt der Name keine Rolle, da er nicht in der 
Schaltung erscheint. Bei Devices mit mehreren Gates wird der Name des Gates 
in der Schaltung dem Namen des Bauteils angehängt. Beispiel: Die Gates heißen 
A, B, C, D und der Bauteilname ist IC1, dann erscheinen die Namen IC1A, IC1B, 
usw. 

 
7. Mit dem CONNECT-Button legen Sie fest welche Pins des Symbols an welchen 

Gehäuse-Pins herausgeführt sind. Bei mehreren Varianten ein und desselben ICs 
können die Pinnbelegungen gleich sein. In diesem Fall können Sie im 
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Connect-Fenster Copy From->bereits verbundenes Bauteil auswählen und sich 
Arbeit sparen. 

 
8. Um mehrere Varianten ein und desselben Bauteils in verschiedenen Gehäusen 

zu realisieren, wiederholen Sie die Schritte 2, 3, 4, 6, 7. Der Schritt 5 wird 
ausgelassen, da das Symbol des Bauteils immer gleich bleibt. Vergessen Sie 
jedoch nicht den verschiedenen Gehäusevarianten verschiedene Namen zu 
vergeben, siehe auch 1. und 2. 

 

Extra Power Pins 
Fügen Sie das zuvor erstellte Symbol Pwr als zusäzliches Gate ein und verbinden 
Sie es mit den richtigen Pins am Gehäuse des Bauteils. Stellen Sie dabei die 
folgenden Parameter ein: Addlevel Request und Swaplevel 0. 
 
 
 
 
Vergessen Sie abschließend nicht die Bibliothek zu speichern und im Control Panel 
zu aktivieren. 
 

Quellen: 
• Trainigshandbuch EAGLE 
• Eagle 4 Manual 


